View Full Version : Glyph client won't start

07-17-2014, 11:26 AM
Sup guys. I can't get Glyph client to work anymore, I have already installed it and downloaded archeage, but now, when I open Glyph client it starts to download what seems like a Glyph update, but the update never ends. It says "Downloading Glyph Client", but when download's complete, it starts downloading again. I've already uninstalled glyph and installed it once more, tried running Glyph Client as Administrator and in compatibility mode, but I couldn't get it to work. Any help would be appreciated. Thanks!

07-17-2014, 06:50 PM
Have checked out the other suggestions posted here (https://support.trionworlds.com/app/answers/detail/a_id/1744)?

09-18-2014, 08:44 AM
it just doesnt load
ive tried everything this is annoying and stupid

09-18-2014, 08:49 AM
i have gotten todload archeage yet the stupid Glyph wont open after i click it even in admin it just wont work
ive done re install , msconfig, everything here (https://support.trionworlds.com/app/answers/detail/a_id/393) and i still cant get it to work

09-18-2014, 10:17 AM
Can i get a registry cleaner or sumtin plz