View Full Version : Why am I getting a direct X error everytime I try to start the game?

07-17-2014, 11:27 AM
I never have problems like these, I have Direct x 11 installed and play games on my laptop all the time, yet I cant play ArchAge because I keep getting "The program can't start because d3dx9_42.dll is missing from your computer. Try reinstalling the program to fix this problem." Not sure what to do at this point...

07-17-2014, 11:35 AM
I also get after I press ok to that error "Error loading DLL: CryRenderD3D9.dll, error code 126."

Still not sure what to do, I dont want to reinstall the game because that took forever. Does anybody have an answer for this?

07-17-2014, 12:03 PM
I am having the same issue. The suggested fix is to update dirextx packages. Well can't install them because my version is newer . Not sure what to do next.

07-17-2014, 12:13 PM
Im trying to reinstall the beta, if this doesnt work than im not sure what to do next. The lack of support is pretty ♥♥♥♥ty.

07-17-2014, 12:14 PM
I rebooted my PC, first time after install and this seems to have resolved the issue, now if only I could get past server selection :P

07-17-2014, 12:18 PM
Tried that and it didnt work, its why i am reinstalling now. Says it has 28 mins left so will see what happens after. Between this not working and the PS4 servers being down so I cant download destiny beta...ugh lol ffs

07-17-2014, 01:54 PM
Still isnt working, reinstalled the whole game client, restarted my pc, waiting for the servers to come back up, still when I press play I get that exact error. Does anybody have a fix?

07-23-2014, 01:54 AM
I Posted a fix here: