PDA

View Full Version : Closed Beta download speed is really pathetic. Please fix it !



SirRender
07-19-2014, 01:18 PM
So I finally got around to getting the Founder's Pack and just started my download hoping to see the game sometime tonight. Then I looked at my average download speed at 200 KB/s. By the time Im done downloading this beta, the closed beta would be over. If this is closed beta, I would really hate to be downloading this at Open beta. Please fix your server connections! :mad:

VincitOmnis
07-19-2014, 04:02 PM
I DL'd at 6.8MB/s. The issue is definitely on your end.

hihihiok
07-19-2014, 04:11 PM
7.6MB/s I see no problems with their server connections. It's on your side. xD

Silentstrike
07-19-2014, 04:13 PM
Agreed, mostly between 4-7 MB/s

Kitsu
07-19-2014, 04:14 PM
I had no trouble downloading in New Zealand, but a pal in KY is taking far too long... so no idea why it's effecting some and not others...

Cherish
07-19-2014, 05:18 PM
13 hours ago I started downloading the game with an avg speed of 900kb/s **yes I know Australia has slow internet* it is currently downloading at avg 30kb/s with another 20+ hours to go.

Feel free to tell me that the problem is at my end and I will smile and say OK. I have downloaded and updated AA since it first went into Alpha and it sure did not take anywhere near the time this is taking.

SirRender
07-19-2014, 11:37 PM
Although my DSL isn't as fast as some but it's steady 650KB/s. Ofcourse I checked before posting here, I download quite frequently and would know if it's on my end. After 11 hours it's now at around 200kb/s and says another 6 hours to go. Also tried resetting the update sessions since it was recommended by someone on the forum but it's not working. At this rate I think I'll spend more time downloading then testing out the game this beta weekend.

Ebony Stallion
07-19-2014, 11:57 PM
Got a steady 2.5 mbps. (Which is above my s team's average).

XanadoX
07-20-2014, 01:09 AM
I had an error patching alpha and I have just download full alpha (10 mb/sec: 25 min).
Now beta has started with 70 kb/s: 90 hours. So it's not our end.

Edited: it has increased speed till arriving 8mb/sec, so it's a weird thing or it's solved.

Ayago
07-20-2014, 03:20 AM
i had no problem 10.8mb/s