View Full Version : Stuck on updating

07-30-2014, 01:34 AM
I got my key to the CBT2, I downloaded Archeage with Glyph yesterday and now I'm stuck on updating it. I tried to update it yesterday, took me like 1 or 2 hours while my PC was almost frozen. When Applying got to 95%+ and "2 minutes remaining" it got stuck. I waited like 5 minutes and nothing, couldn't even kill the proccess cause everything froze. I tried to do it this morning, but got the same result - "1 minute remaining" and nothing happening. My PC isn't some new gaming monster, but why the hell unpacking games like this always eat more hardware than the actual game? This is ridiculous. I'm trying for the third time, and will try to be more patient, but if that won't work or I won't get any good advise I will just delete it and forget...

Edit : This time I gave it like half hour of extra time. The "1 minute remaining" changed into 20 and the memory usage went down. Looks like it's gonna work. Not sure if deleting Glyph's Appdata or launching as Admin really helped or I just had to be more patient.

07-30-2014, 03:59 AM
https://support.trionworlds.com/app/chat/chat_launch contact support in an hour or 2 https://support.trionworlds.com/app/chat/chat_launch