PDA

View Full Version : Massive delay on all abilities Auz/nz players



dmannz
08-04-2014, 06:48 PM
Hi all I have 90/mbs internet connection speeds tests say local ping is 3ms
Yet there is a 1 to 2 second delay on my skills in pvp this has also been the case with other
Australian and nz players. Trion / rift had the exact same problem in which they fixed it
Basically it is almost impossible to pvp in arena and in world pvp if there are good

Can trion please look into this so that on launch we are not gimped


Please don't give me the "it's your internet" response because it isn't ....


Thanks keep up the good work

TheFell
08-04-2014, 11:13 PM
... the game servers aren't located in Australia/NZ so your local ping means nothing,.... its just your connection... try ping test to Texas.

NZ1
08-04-2014, 11:20 PM
the server response times are consistently no different than any other mmo

DvsMK2Supra
08-05-2014, 04:44 PM
I'm from NZ and run around 2-300ms pings to the trion servers...
Other games try to help counter this delay of hitting abilities with the ability queue and im hoping they bring that into this game

Friar Tuck
08-05-2014, 07:34 PM
Right now on Omega server the lag is unplayable. Alpha does not seem affected. But last night (Oceanic time) I could barely use my abilities and fighting quest mobs my level was almost deadly. Sailing on the sea of using carriages was like a series of complete stops and teleports. [Ed. Ppl are saying it's a server side problem.

Lollis
08-05-2014, 07:55 PM
I had the massive delay on the last day of the beta for like the whole day and i like in the US and i didn't have it the whole beta but it went away later in the day idk why

Brutus
08-05-2014, 09:18 PM
http://forums.archeagegame.com/showthread.php?15105-We-want-ability-queue-to-fix-latency-issues-!!