PDA

View Full Version : Can't Use While Carrying a Tradepack



Lerxst
08-16-2014, 07:44 PM
I get this any and every time I go to equip a ship's harpoon/weapon. It happens on my ship and everyone else's. This started on the Scarecrow upgrade quest and has been bugged since. Logging out does nothing. Building another trade pack and picking it up (Yes, I can still equip another trade pack) does nothing. For the sake of weapons/ships, the game has me forever labeled as "carrying a trade pack" which means I can't defend myself at sea...

Lerxst
08-30-2014, 12:58 AM
I'm bumping this. It started in CB3, and continued into CB4. My glider was removed, I was butt naked and still received the error when trying to equip the harpoon.

Furthermore, my alt is also plagued by it as well. Totally new character, also experiencing the same error.

Prior to this, I was able to pick up a harpoon at will.

Sicknessink
08-30-2014, 11:30 AM
the reason is you have a glidder equipted. just manually take your glidder off by clicking c then click glidder it will unequipt. then you can pick up harpoons and stuff. i had the same issue.

greenllama
09-01-2014, 04:58 AM
Read his second post lol. Also, usually the glider is automatically unequipped when you try to pick up another tradepack.

I've had this issue as well but when I tried a second time it worked for me so idk what to tell you.

Gyabire
05-22-2017, 12:51 AM
This is still an issue.

It happens to me every time I try to use the harpoon on my clipper