PDA

View Full Version : Muzzy: 1.5x is NOT activated....



DevTracker
12-18-2017, 12:00 PM
Hello all,It was originally announced with 1.5, but that was updated to double all the time. (though different things granted at different times). We have checked and can confirm that the double everything even is functioning properly. If you are seeing issues, please submit a support ticket with your details and description of the issue.

Jump to post... (http://forums.archeagegame.com/showthread.php?t=335498&p=2660952&viewfull=1#post2660952)