PDA

View Full Version : Awful FPS (Nvidia 970)



Amaren
10-07-2014, 12:53 PM
Hi guys.

Just bought a full new rig, with the aim of being able to MAX Archeage graphics out.

Intel i5 4690k
8GB Corsair Vengeance RAM
Samsung 840 Evo 256gb SSD.
Nvidia 4gb GTX970

Now, I've also got a laptop with the exact same issue, Quad i7, 8GB RAM, Samsung SSD and Nvidia 780m.

I can run PERFECTLY in DX9, no issues. But whenever I switch to DX11, frame rates are all over the place, especially when panning around with the camera. 80fps > Camera 360 > 10fps > Stationary Camera 80fps.

I've tried pretty much everything. Latest drivers, power settings, Nvidia Control panel tweaking etc...

Is there an Archeage specific setting I can change?

If someone would just say, it's archeage being poorly optimised for Nvidia cards or Nvidia drivers poorly optimised for Archeage, then I'll leave it alone, however it's really bugging me.

Any help/advice?

Kryadan
10-07-2014, 12:54 PM
Archeage is poorly optimized for computers.

Solonor
10-07-2014, 01:09 PM
Hi Amaren,

please could you go back into your Nvidia Control Panel and set every option for Archeage back to "Application controlled". Most of the times this is causing various issues between games and nvidia drivers.

If you're playing in fullscreen mode, you could also try setting the option "vertical sync" as this option is trying to keep your FPS stable while turning/moving around. If the problem still persists, try disabling AA ingame (I know it looks sh*t afterwards but it is worth a try to find out if that is causing these issues)

I noticed quite a few posts on the forums where people seem to have this problem and most of them think that AA is the problem.

Amaren
10-07-2014, 01:22 PM
Hey Solonor,

Appreciate the reply.

Sadly, I've tried all of the above previously, to no avail.

Bagabontu
10-07-2014, 07:48 PM
I also get low fps and i'm using two GTX 560TI but i can't use both of them because Archage and nvidia don't want to fix this serious problem which many people facing it.

Amaren
10-09-2014, 11:40 AM
Just had another 970 to play with, still the same issue, albeit with slightly better FPS when camera panning.

My friend has a ATI 280x can play the game fine on DX11 on very high and doesn't have this problem.

Maybe it's an Nvidia problem after all?

ToBbErT
10-09-2014, 11:44 AM
Nope i also have issues with dx11 along with many other amd gpu users. Its related to the engine i think.

Veos
10-09-2014, 11:57 AM
If you haven't already, try changing the UI to 80% or 120%. Also transferring AA to my SSD improved my FPS.

Amaren
10-09-2014, 01:27 PM
If you haven't already, try changing the UI to 80% or 120%. Also transferring AA to my SSD improved my FPS.

I have Archeage installed on my SSD.

UI change made no difference.

/sigh.