PDA

View Full Version : Incorrect Patron time remaining



TchanTchong
10-24-2014, 02:58 AM
Hello,
I bought patron time with in-game gold for almost a month now. Patron time was put into my account indeed, and then I got enough money for more 2 APEX and bought 1 more month of Patron Time.
But this time, I once again lost 2400 credits, but the ingame timer is wrong. It says it finishes in 9 days, but in the glyph website, it says I still have 1 month + 9 days.
So, I read the forums and even with you guys saying the Patron Time will not be disabled in my account when the in-game timer ticks off, I still know some friends that had this same issue and Patron Time was disabled on their account.
Now, I dont want to lose my Patron Status because I have claimed land and I dont want to lose them. I know that even if I lose the buff I still have 2 weeks, but I dont want that kind of headache in the future, so I'm already taking the precautions.

I did submit a ticket, its reference number is 141024-000025
Thank you very much for the patience.

TchanTchong
10-26-2014, 02:35 AM
Can anyone in the staff help me please?

Fasti
10-26-2014, 05:13 AM
Hey there!

It looks like you've already got a ticket submitted, so please hang in there. If you're seeing the Patron time you have paid for is not showing up when you sign into your account management page (https://archeage.trionworlds.com/account/profile/manage-game!input.action?dd=1), our support team will work with you to get that squared away.