Closed Thread
Page 1 of 10 1 2 3 ... LastLast
Results 1 to 10 of 96

  Click here to go to the first Archeage Team post in this thread.   Thread: 1/11 -- North American players receiving black screen before server select [RESOLVED]

  1.   Click here to go to the next Archeage Team post in this thread.   #1
    ArcheAge Associate Producer Celestrata Bloodsong's Avatar
    Join Date
    Jun 2015
    Location
    Austin, TX
    Posts
    5,616

    1/11 -- North American players receiving black screen before server select [RESOLVED]

    1:05 PM PST Update: The black screen issues should now be resolved and players can log in. Thanks for your patience!

    Hello Adventurers,

    We've found that players are receiving black screens when logging into the game, before they reach server select. Our team is already on it and are working to fix the issue. We'll keep this thread updated with anything new when it comes in.

  2. #2
    Senior Member Katastrophie's Avatar
    Join Date
    Apr 2014
    Location
    Texas
    Posts
    196
    And let me guess after this the grey screen issue will be back? Rinse and repeat, right?
    Kat
    Kraken West
    Reckoning East

  3. #3
    Junior Member Zikas's Avatar
    Join Date
    Jan 2017
    Location
    Reckoning
    Posts
    1
    nooooo i want to play :'(

  4. #4
    Junior Member
    Join Date
    Jan 2017
    Posts
    2
    Its so weird I feel like Im playing an Early Access game. But as memory servers this game has already officially launched right? I mean I remember playing back when it first launched on NA.

  5. #5
    Junior Member
    Join Date
    Jul 2014
    Posts
    1
    Deja ♥♥♥♥in vu

  6. #6
    Junior Member Kiawa's Avatar
    Join Date
    Jan 2017
    Posts
    4
    RIP Mistmarrow...

  7. #7
    Junior Member
    Join Date
    Dec 2016
    Posts
    9
    Here the game stops loading the letters and closes, and does not leave it

  8. #8
    Junior Member
    Join Date
    Aug 2014
    Posts
    2
    Do you guys need any system info from us or do you already have an idea of what the issue is?

  9. #9
    Ridiculuos

  10. #10
    Junior Member
    Join Date
    Dec 2016
    Posts
    4
    How do these issues CONTINUE to return? Does your team actually fix the issues or just bandaid temp fix? Not impressed when the same issues return which were there on fresh start launch

Closed Thread
Page 1 of 10 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts