+ Reply to Thread
Page 2 of 23 FirstFirst 1 2 3 4 12 ... LastLast
Results 11 to 20 of 230

  Click here to go to the first Archeage Team post in this thread.   Thread: Europe Server Select screen?

  1. #11
    Junior Member
    Join Date
    Mar 2017
    Posts
    5
    I have exactly the same problem. After downloading fresh AA I managed to get in once. I got disconnected and experienced the same problem again.
    I can log in on my other PC...

  2. #12
    Junior Member
    Join Date
    Mar 2017
    Posts
    5
    I have changed my internet connection and it works! When I switch back to original one it doesnt. It seems that problem is not from player side, but login server

  3. #13

    EU Login issue

    i am facing this problem too and it started yesterday evening MARKETPLACE update before that everything was fine for me. i have 3 internet and all 3 failed so it's certainly not me.

  4. #14
    yes intro runs of trion/cryengine and then black screen for like 6-10 seconds and then closes itself, NA is workin fine for me with all my other accounts including fresh start ones but only NA works not EU. I even tried down-grading version and re-patch it, it's still same. They messed it up after marketplace update last evening.

  5. #15
    Senior Member
    Join Date
    Jan 2015
    Location
    Aranzeb
    Posts
    121
    After second fresh install, I managed to get in for about 10 minutes... Then, got disconnected by the gods and never saw the server select screen again.
    I am

  6. #16
    No response from Trion, all of my accounts even the ones i made just now can't get on EU server only NA is working. it's so infuriating no wonder why AA is a dead game in NA.

  7. #17
    Same problem to enter game from 4h, after glyph loading game open, next see some image screen logo trion itd before show serwer list wait and crash. Its same again many times and cant enter to UE serwer list. But in NA serwer is normal can play. I send to support report technical issue but no ansers.

  8. #18
    After 17 hrs of struggle i got in, as hero i of my faction i lost many events for leaderships and honour points + the trade run i had to do. Can we who weren't able to get-in will get some Compensation??

  9. #19
    Junior Member
    Join Date
    Mar 2017
    Posts
    1
    same problem here !!! How to fix it ??

  10. #20
    I have the exact same problem. I've tried literally everything and I couldn't log in to EU. NA work perfectly but EU server screen doesn't seem to appear at all. I am sad that I am spending my patron days for nothing... :C GM's plz help-uru.

+ Reply to Thread
Page 2 of 23 FirstFirst 1 2 3 4 12 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts