+ Reply to Thread
Results 1 to 3 of 3

Thread: Error 1004

  1. #1

    Error 1004

    Got a new SSD and i am trying to install AA onto it but after the base game is downloaded i keep getting the error 1004. Right after it gives me another small download and then the 1004 error....and it did this like 3-4 times like as if i was downloading one patch after the other.....so i just stopped for now and came here. Please help. Thx.

  2. #2
    Fixed it myself. Thanks anyway. Great customer support!!!


  3. #3
    Junior Member
    Join Date
    Dec 2015
    Can you please tell me what u did im currently having this problem, game tries to patch 233mb but giving me error 1004 at the end of Verifying Archeage bar. I tried everything on General Glyph Troubleshooting, uninstalled and installed game, yet couldnt find a solution :/

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts