+ Reply to Thread
Results 1 to 3 of 3

Thread: Unable to purchase

  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    3

    Unable to purchase

    Is anyone else unable to purchase anything? I am unable to purchase anything, and my wife is having the same issue. My wife is also having the same issue, as is another person in our guild. We’ve checked with our bank and they don’t have a record of any charges being blocked by them. We’ve also tried alternate payment methods, and still receive the “unable to purchase” screen. We’ve each submitted tickets:
    1196929
    1196778
    Hopefully there is an easy fix, as we’ve had no issues purchasing anything previously.

  2. #2
    Senior Member
    Join Date
    Feb 2016
    Posts
    186
    I was having an issue, but it seems to be working now.

  3. #3
    1191325 same issue and still not working after first fix?

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts