+ Reply to Thread
Results 1 to 2 of 2

Thread: Still no labor regen or ability to use labor pots

  1. #1
    Junior Member
    Join Date
    Oct 2019

    Still no labor regen or ability to use labor pots

    Have played PTS since day 1 - no labor regen on any PTS server several characters on each. The pots from the credits shop don't work because it says need to have drained 1,000 Labor... Fluffy rolled out today, same issue need to have spent x amount of Labor from whichever pot he gives you. The only way I was able to receive labor was through the Archepass...after receiving and spending the labor received there i expected to be able to use the pots nope..still no regen, haven't been able to do much progression wise with gear just grind up to a certain area. I would expect this labor issue to be fixed since we're nearing the end of PTS ^^ also not hearing anyone address this even though i see lots of people reporting the issue

  2. #2
    I'm also a bit shocked that this has not been addressed. I don't even think they've let the player base it is a known issue even though it is wide spread.

    I can't even fathom the uproar if this issue occurs on Launch Day.

    PVP is practically unplayable without labor.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts