+ Reply to Thread
Results 1 to 5 of 5

Thread: Territory package delivery

  1. #1

    Territory package delivery

    Is it intended, that territory package do NOT count towards the respective quest, once you get killed while having the package?

    I made package, paid all materials, tried to deliver and was killed, got rez, took my package again and delivered.
    the gamigo npc took the package, but quest did not complete, but all lats and labor consumed...

  2. #2
    Senior Member Herzeleid's Avatar
    Join Date
    Oct 2014
    Location
    Orchidna
    Posts
    913
    This quest for me fails to give rewards quite often. It's a real pain in the back. And it does not depend on dying, I never died with that pack. I even tried picking different profs thinking it might be the pack, but it isn't that either. I think it might just be server lag, like pretty much everything in this life related to Archeage. Just two days ago all 3 of my characters delivered without any reward, so that is the most likely scenario imo.
    Proud green pirate, fervent activist of the Tumbleweed Nerf Society

  3. #3
    yes, yesterday i had it again, and this time no death, just straigth crafting the package and running to npc and .... no reward.
    Still coins get consumed and Labor and package disappeared.
    Also the Chat log said it was "delivered" but nothing else.

    Maybe it is like all in this game...just random Chance to get a reward^^

  4. #4
    Junior Member
    Join Date
    Sep 2014
    Posts
    6
    Restart the quest, look for it in the quest and cancel it, possibly you are making the journey nuia haranya and have the opposite mission, if you have one it does not leave you another for doubling the quest a day.

  5. #5
    it's NOT the trade package we deliver to other continent.
    It's about the territiry package we craft in Castle and deliver right to the npc in the tower

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts