+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

  Click here to go to the first Archeage Team post in this thread.   Thread: Cannot Update Payment Info

  1. #1
    Junior Member
    Join Date
    Sep 2014
    Posts
    3

    Cannot Update Payment Info

    I already submitted a ticket via the website, but the confirmation e-mail told me I'd potentially be waiting 96-120 hours for a reply. I would really like this to be fixed/seen sooner than that so I can get Patron before all the land is completely gone, so I'm posting this here in hopes that it's seen by someone who can help/pass it along to someone who can. If anyone is having this same issue or has seen another post that lists this as a known issue, please share below.

    "I was trying to add a payment option for my account to purchase a one month subscription for Archeage, but every time I try to save the payment option, I'm sent to a page to enter a verification code for my account because I am logged on on a new device. I am sent a code and when I enter it, I'm sent to a 404 page and my payment info remains unsaved. Please reply as soon as possible. I'd like to get my Patron status for this game."

    Update: Turns out that my e-mail that was associated with my account was never verified and it wasn't required to be to download the Glyph client or play the game. I verified my e-mail and managed to get my payment option to save. If you're having this same problem, double check that your associated e-mail is validated. Hopefully this fixes the issue for some people experiencing the same thing.

  2.   Click here to go to the next Archeage Team post in this thread.   #2
    Community Team
    Join Date
    Mar 2014
    Posts
    525
    Hey there. The wait time is the result of many tickets being submitted. We do tickets in the order that they are received, and as such, there isn't a way to bypass that wait time unless you have access to Live Chat.

  3. #3
    Junior Member
    Join Date
    Sep 2014
    Posts
    3
    Quote Originally Posted by Kiwibird View Post
    Hey there. The wait time is the result of many tickets being submitted. We do tickets in the order that they are received, and as such, there isn't a way to bypass that wait time unless you have access to Live Chat.
    I appreciate the reply and I understand. I'll just wait and hope that not all the land is gone by the time it's fixed.

  4. #4
    Junior Member
    Join Date
    Sep 2014
    Posts
    18
    Quote Originally Posted by Kiwibird View Post
    Hey there. The wait time is the result of many tickets being submitted. We do tickets in the order that they are received, and as such, there isn't a way to bypass that wait time unless you have access to Live Chat.
    Can we please get an official response from Trion, even if it is just "We are aware of the issue please submit a ticket if your account if having this issue." Because from taking to people in game and reading the numerous posts about this on the forum this is not an isolated incident. Too many people have this issue for you to not respond acknowledging the issue and letting people what they have to do to fix this. Like an official sticky or list this as a known issue.

    Seems like common sense to submit a ticket but gaming companies in general do not have a very good rep when it comes to replying to tickets and actually providing a solution.

  5. #5
    Senior Member
    Join Date
    Sep 2014
    Posts
    109
    ya...IM HAVING THE SAME ISSUE..

  6.   This is the last Archeage Team post in this thread.   #6
    Community Team
    Join Date
    Mar 2014
    Posts
    525
    In order to fix this, you have to submit a ticket. A GM will have to review your account and manually make some changes. You can try adding another payment method in the meantime if it allows, but beyond that, it's really something that you're just going to have to contact support about.

    We do apologize for our support wait times, but with such high traffic, it's important that we do not allow the forums to become a means for users to skip ahead of others that are already waiting for their tickets to be addressed.

  7. #7
    Senior Member
    Join Date
    Sep 2014
    Posts
    109
    Quote Originally Posted by Kiwibird View Post
    In order to fix this, you have to submit a ticket. A GM will have to review your account and manually make some changes. You can try adding another payment method in the meantime if it allows, but beyond that, it's really something that you're just going to have to contact support about.

    We do apologize for our support wait times, but with such high traffic, it's important that we do not allow the forums to become a means for users to skip ahead of others that are already waiting for their tickets to be addressed.
    I do understand that, but come on..this is the issue shouldnt be happening in the first place. This is just the payment system, and there are tons of the people who are having the same issue =.= btw I did submit the ticket

  8. #8
    Junior Member
    Join Date
    Sep 2014
    Posts
    26
    Quote Originally Posted by qqninja123 View Post
    I do understand that, but come on..this is the issue shouldnt be happening in the first place. This is just the payment system, and there are tons of the people who are having the same issue =.= btw I did submit the ticket
    I'm in the same boat.

    Another question they need to be answering.... If it takes them betweem 4-7 days just to respond and not fix anything yet.

    That going to start really becoming an issues because we shouldn't pay for the support team to find time to fix an issue that should have been..... automated to work in the first place.

  9. #9
    Junior Member
    Join Date
    Sep 2014
    Posts
    3
    I'm also in the same boat, but I did end up talking to live chat support. After a long 6 hours in queue.... the "GM" said that there were issues with my account and he made fixes to my account and for me to try again in 15 minutes and payment info would update and save. Needless to say after 15 minutes I tried again, then tried in an hour, now its 2 days since then with continuous attempts and I get the exact same result. Either it goes back to the "put in your payment info" or it will ask me for my authentication code and then give me an "Error 404". I would love an explanation as to why this is happening, even after waiting 6 hours for a GM to "fix" the problem with my account which didn't fix a damn thing. Now the real question is, do I wait another 6 hours for the same result? or just hit the uninstall button.

  10. #10
    Posting because I have the same problems as you guys.
    Tried Live Chat 2 times and I literally had to wait more than 9 hours to get connected.When I did get connected I was away from my computer, the second time I was not paying attention to browser. This is something that I should not even have to send a ticket for.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts