+ Reply to Thread
Page 3 of 7 FirstFirst 1 2 3 4 5 ... LastLast
Results 21 to 30 of 61

  Click here to go to the first Archeage Team post in this thread.   Thread: [COMPLETE] Archeage EU Maintenance - 1AM UTC - April 30th

  1. #21
    Junior Member
    Join Date
    Aug 2014
    Posts
    27
    Me too, unable to get to server selection screen after cinematics. Seems like the previous bug with IP's and updates failing to load for some people and not others, even though there is no patch this time.

  2. #22
    The logon to EU WAS working at 0700 UTC+1 but I've just tried at 0825 UTC+1 and having the same experience as those above

  3. #23
    Junior Member
    Join Date
    Mar 2019
    Posts
    4
    Imagine not being able to put the game in good condition for months lol.

  4. #24
    Junior Member
    Join Date
    Feb 2019
    Posts
    25
    You broke something that was working AGAIN GAMIGO! Still waiting to hear what and when compensation is for the previous 2 weeks of breaking servers, Guess you gonna have to think of even more now

  5. #25
    Senior Member
    Join Date
    Nov 2014
    Posts
    109
    cant login in EU Taris, game crashed after videosession. Login in NA works

  6. #26
    Junior Member
    Join Date
    Dec 2018
    Posts
    3
    black screen after cinematic and the game is closing

  7. #27
    Junior Member navirri's Avatar
    Join Date
    Sep 2014
    Posts
    17
    same problem, no login possible

  8. #28
    Junior Member
    Join Date
    Apr 2019
    Posts
    5
    zzzz fix the game we pay for ,ty

  9. #29
    Junior Member
    Join Date
    Apr 2019
    Posts
    12
    +1

  10. #30
    Junior Member
    Join Date
    Dec 2014
    Posts
    11
    +1

+ Reply to Thread
Page 3 of 7 FirstFirst 1 2 3 4 5 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts