+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13

Thread: Fps

  1. #11
    Junior Member
    Join Date
    Dec 2019
    Posts
    3
    Ok then let me double dumb it down for you. The constant FPS issues that have been affecting multiple people over the past few days, coincidentally starting after the last patch update, may actually not have to do with archepass. Considering the archepass was released weeks ago. Yes! There is definitely a small stutter every time you gain xp or kill a mob during the archepass quest, but a lot of people are experiences constant frame drops while doing nothing even related to archepass. For instance! My game ran smooth and had no issues, until after the update last week. Now I can barely walk anywhere without stuttering around the screen and getting my head blown off in west Hiram or walking to my next crop bundle to pick up.

    So in the end let’s all just Kumbaya and agree that this is an AAU issue, and has nothing to do with the op pc setup. Stay beautiful pocket. Hearts and kisses

  2. #12
    Junior Member
    Join Date
    Sep 2014
    Posts
    4
    Thanks for all the help guys,

    I knew my CPU was old but did not realise it would affect it that much, if I get the ryzen3600 would that sort out my problems?
    I have tried to overclock my CPU and think its a little better than before but not enough for my liking.

    Think I had better start saving as it will have to be new CPU, MB and Memory.

  3. #13
    Junior Member
    Join Date
    Dec 2019
    Posts
    2
    First of all getting a new and better CPU + ram will definitely improve your fps, however, getting that low fps sounds like more than just your cpu issue. I played aau on my ancient 3770k and gtx970 on high settings with TXAAx2, 1080p resolution, and it runs at mostly 58-80 fps roaming the world, 38-48fps around housing areas and 15-20ish fps in very large raids/battles.

    The CPU is pretty old, but Archeage is also pretty old...it could be the game or hardware problems idk. But just for your context, I'm also running the game on 9600k OC to 4.9Ghz + RTX2060 OC to 2025mhz core clock, 15Gbps memory clock, 16g ram @3000mhz, CAS15 maxed setting with TXAAx4, DX11 on 1080p, and I get 80-125fps roaming the world, 45-60 fps around housing area and 20-30ish in large battles. I recently got a 144hz 1440p gsync monitor, and it seems roaming i still get 80-125ish fps, haven't tried large scale battles yet......just have to tune down settings in order to hit a smooth fps in large battles for me.

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts