+ Reply to Thread
Results 1 to 3 of 3

Thread: I have a problem quest holy water

  1. #1

    I have a problem quest holy water

    https://imgur.com/2sFMDaa
    I have to go to the library I do the boses when I try to talk to npc slevin, before entering 4 boss no mission appears to me condense the holy water apart I have been going through the entire library 4 times there is nothing

    https://www.youtube.com/watch?v=Djj7dhe9K2A&t=287s
    In this video when he enters the 4 boss, the quest appears directly when I arrive I have nothing
    Does anyone know that I'm losing myself I'm already going crazy

  2. #2
    Senior Member Turambaredolas's Avatar
    Join Date
    Jul 2015
    Location
    Taris (Nuia) | Alexander (Haranya)
    Posts
    2,403
    I am not sure if it is still the case:
    In the old quest line you often had to equip the ring or quests couldn't be started or completed.
    Did you wear the ring when you tried to talk to slevin?
    A child of song, a child of rage
    Abandoned in another age
    Now ancient hate and rhymes that bind
    Make paradise a tomb divine
    And demons trapped in beauty’s thrall
    Hunt those who heed the bloodsong’s call.

  3. #3
    If I tried everything, remove the ring and everything does not come out, no mission or to give slevin

    fence game of ♥♥♥♥4 is so dead that nobody is even able to answer in the forum

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts